Assist'Mat Paye

Utilisation du produit

Version 3.0

Assist'Mat Paye est un programme d'aide à la gestion et à la réalisation des bulletins de salaire d'une assistante maternelle agrée.

Assist'Mat Paye vous permet de gérer jusqu'à 5 enfants en garde. Du calcul des heures de gardes (en une ou deux périodes journalières pour les enfants scolarisés), au forfait journalier et/ou au taux horaire, jusqu'à la réalisation des bulletins de salaire (en net ou en brut), en passant par la gestion des indemnités, des frais de repas, du calcul des jours fériés... tout ceci est pris en charge facilement.

Le principe d' Assist'Mat Paye est de garder en mémoire toutes les coordonnées des intervenants, les coefficients de salaire, et surtout de permettre de remplir le tableau des horaires journaliers "à la volée" sans calculer ces soustractions d'heures si pénibles ; puis d'imprimer les bulletins de salaire.

Assist'Mat Paye est un logiciel shareware, qui peut être testé sur un bulletin de salaire, après quoi, en cas de décision d'utilisation prolongée, il vous faudra vous enregistrer (dans le logiciel, bouton "enregistrer la version") ; dès lors que vous serez en possession de vos codes de licence, il vous sera possible d'utiliser toutes les versions d'Assist'Mat Paye 3.xx sans autres formalités. Dans le cas contraire, vous devrez désinstaller ce produit par l'utilitaire de désinstallation de Windows.

Merci de votre soutien.

L'auteur ne saurait être tenu pour responsable de tout dysfonctionnement pouvant intervenir sur votre machine, ni de toute mauvaise utilisation des données.

De plus vous ne pouvez modifier le contenu ou le sens du logiciel ou de son aide ou de tout fichier et répertoires en rapport, ni même en utiliser tout ou partie à d'autres fins que celles permises par le logiciel sans l'accord écrit de l'auteur.

Attention :

Il est conseillé malgré la présence sur mon site d'un fichier de mise à jour des coefficients (taux.txt) de vérifier régulièrement que vous êtes en possession des derniers tarifs employeurs en vigueur.


Album photo

Au tout début... :

... Ce fût lorsque je voyais ma charmante ;-) épouse se débattre avec ses calculs d'heures afin de remplir les peu alléchants formulaires pré-imprimés de l'URSSAF.

Connaissant un peu le maniement d'Excel®, je me suis attelé à mon tableur afin de lui faciliter la tâche. Après tout, soustraire des heures/minutes, l'ordinateur est là pour ça !

Mais je me suis laissé prendre au jeu.... vous connaissez l'adage qui prétend que l'informatique permet de gagner du temps afin de pouvoir faire l'informatique !... et du tableau sans mise en forme est né un classeur entier avec l'impression des bulletins, la mise en place des coordonnées employeur et employée, ainsi que des coefficients divers.

Puis d'améliorations en améliorations, souvent devant la demande des utilisateurs, qui proposaient tous des "petits plus" ;-) ; Assist'Mat Paye . est devenu un petit soft à lui tout seul...

C'est alors qu'est née l'idée de la refonte totale du produit pour le rendre autonome (combien m'ont demandé comment faire sans ce "fichu" tableur Microsoft !).
Ayant fait l'acquisition de la dernière version de Delphi, la version 3.0 a fait son chemin... Et quelques centaines d'heures et milliers de lignes de codes plus tard, je peux enfin vous proposer une version toute fraiche d'Assist'Mat Paye .

Néanmoins devant la masse de travail et le temps imparti, je ne pouvais plus laisser cette version en freeware, et en ai fait un shareware en laissant la possibilité de tester sur un bulletin de salaire.
Cependant, c'est sans regrets d'avoir pu aider quelques 4000 utilisateurs des versions 2.xx dans leur travail, de façon libre... Mais toute bonne chose a une fin ; et pour la pérrénité d'Assist'Mat Paye , il fallait que cela change.

Version 1.xx:

Les versions 1.x possédaient alors encore des onglets mensuels avec un tableau et un bulletin de salaire sur chacun d'eux. L'avantage était de garder une trace de chaque mois... L'inconvénient majeur était l'obligation de garder un modèle vierge, et d'en créer un exemplaire par an sous un nom explicite. En fait, la mise en mémoire ad eternam de ces données ne présente pas un intérêt essentiel, devant l'obligation de conserver les bulletins à vie. La décision de changer de formule était prise... Ainsi est née la version 2.0.

Dans la foulée, les onglets se sont masqués, et l'on circulait d'une page à l'autre grâce à des macros qui sont apparues en même temps, ainsi que quelques petites modifications mineures, et surtout l'apparition de cette page d'aide, puisque la décision de faire bénéficier de ce travail à quelques internautes employeurs de "nounous", sous forme de freeware (gratuiciel pour les puristes linguistes), fût prise dans la foulée.

Version 2.01:

Modifications mineures de bugs, dont difficultés à l'ouverture sur certains écrans de moins de 17' et mauvaise attribution de la macro imprimer sur le dernier tableau (le bulletin ne pouvait être imprimé par le bouton de commande... gênant !)

Version 2.11:

Passage à l'Euro en parallèle avec le Franc.
Correction de bugs mineurs comme la case 'Nom' de l'employée trop petite pour les noms longs
Cette version n'a jamais eu le temps d'être "on line", car la 2.2 l'a suivie de très près ;-)

Version 2.2:

Mise en place du système de gestion des forfaits journaliers.
Améliorations graphiques diverses.
Correction des macros qui ont été modifiées lors de la 2.11

Version 2.3:

Modification permettant l'usage d'horaires "coupés" pour les enfants gardés avec une coupure le midi.
Correction de macros.

Version 3.0:

Version entièrement autonome programmée sous Delphi 6.0 Professional.
Passage en shareware.
Possibilité de gérer les comptes et bulletins en net, mais aussi en brut.
Ajout de la possibilité de gestion de 5 enfants en une seule et même application
(utile pour les assistantes qui utilisent Assist'Mat Paye).
Garde l'image de tous les bulletins édités.
Gestion des indemnités d'entretien horaires ou journalières.
Gestion des jours fériés travaillés.
Fichier d'aide en CHM disponible à tout moment dans le programme.


Contact

Pour me contacter...

Par mail : jlperrot001@wanadoo.fr

Par courrier : Dr. Jean-Luc PERROT
31, rue Elisée Reclus
25000 BESANCON

Pensez à joindre une enveloppe retour en cas d'absence d'adresse email.

Pour s'enregistrer...

Adressez moi par courrier :

- Vos coordonnées (nom, prénom obligatoires) (adresse facultatif)
- La clé retrouvée dans la case bleue de la fenêtre d'enregistrement. (obligatoire)
- Votre adresse mail (ou une enveloppe retour timbrée à défaut)
- Le règlement d'un montant de 20 €

Vous recevrez en retour les données de la licence à entrer dans le logiciel en cliquant sur "enregistrer la version" sur la page d'accueil.
Toute demande incomplète ne pourra se voir honorée.

Pour visiter mon site...

http://jlperrot001.free.fr


Enregistrer la version

En cliquant "s'enregistrer", vous déclenchez la procédure d'identification personnelle. Une première fenêtre (si vous n'êtes pas encore enregistré) vous explique la procédure à suivre ; validez la si vous possédez vos codes.

Une deuxième fenêtre vous propose d'entrer le nom de l'utilisateur, le N° de licence et la clé tels qu'ils vous ont été fourni en respectant bien la casse (majuscules/minuscules).

Puis validez par OK.

En fournissant correctement ces renseignements, cela prouve votre enregistrement en règle ; et vous permettra d'utiliser Assist'Mat Paye sans limitations.


Accueil

Vous êtes ici sur le "tableau de bord" d'Assist'Mat Paye .

Un calendrier vous est proposé à titre de renseignement. Il n'a aucune incidence sur la suite des opérations.
Par défaut, il affiche la date du jour.

En premier lieu, enregistrez vous si vous possédez déjà vos codes. [bouton Enregistrer la version]

La prochaine étape est de renseigner les paramètres. [bouton Paramétrer]
Cela permettra au logiciel de connaître toutes les données utiles à la gestion des gardes des enfants
(coordonnées des employeurs, des employées, nom des enfants, salaires, indemnités, etc...)

En terminant de paramétrer, vous reviendrez sur cette page d'accueil. Vous verrez alors apparaître le prénom de l'enfant qui a été sélectionné sur les onglets paramètres dans la case [enfant sélectionné], cela vous permet de toujours savoir pour lequel des cinq enfants possibles vous travaillez.

Il faudra ensuite entrer dans le vif du sujet pour renseigner les heures de garde pour le mois désiré. [bouton Calculer le salaire]

Comme précédemment, vous allez revenir à cette page lorsque vous aurez terminé la création et l'impression du bulletin de salaire pour la garde de l'enfant qui était sélectionné.

A partir de là, vous pouvez revenir aux paramètres [bouton Paramétrer] pour choisir de travailler avec un nouvel enfant afin de réaliser une nouvelle fiche de salaire.

Deux autres boutons vous sont offerts (toujours à condition d'avoir sélectionné un enfant - Rappelez vous bien ceci: Vous devez toujours avoir un travail sur un enfant et un seul dans le même temps) ; il s'agit du [bouton Revoir un mois] et du [bouton Revoir un bulletin]. Ils permettent de retrouver une ancienne grille des horaires de garde d'un mois précédant, pour le premier ; et de revoir l'image (format JPG) d'un ancien bulletin, pour le deuxième.

Le [bouton Aide] devrait vous emmenez là où vous êtes actuellement. Mais cela semble évident ;-)

Le [bouton Quitter] vous ramène sous Windows.


Nouvelle page 2

ràz pour l'enfant

partie droite:

Onglets enfant

partie haute:

Onglet Employée

Onglet Employeur

Onglet Salaires

Onglet Indemnités


Employée

Il suffit ici de rentrer les coordonnées complètes de l'assistante maternelle afin qu'Assist'Mat Paye puisse les utiliser en remplissant les bulletins de salaire.

Les numéros de téléphone n'apparaissent pas, bien sûr, sur les bulletins.

Employeur:

Idem sur cette page en ce qui concerne les coordonnées de l'employeur.

S'ajoute un cadre concernant l'enfant en garde: Prénom + Nom + Date de naissance
qui permettra de renseigner l'enfant en garde sur le bulletin afin de pouvoir les classer ultérieurement.

Onglets:

Il faut renseigner ces feuilles de coordonnées pour chaque enfant en garde (onglets utilisés).

Cela permet de pouvoir travailler avec 5 enfants de nom différent (utile pour les assistantes utilisatrices) et/ou avec 5 assistantes différentes si nécessaire.

Remarque : Si deux enfants devaient avoir le même prénom, il est souhaitable de les distinguer dans le cadre "enfant en garde" en spécifiant par exemple l'initiale du nom ; afin de ne pas mélanger les images des bulletins conservés.


Salaires

Attention cette page est à remplir pour chaque enfant gardé (pour chaque onglet).

Mode de calcul:

Il faut choisir (possibilité de choisir différemment pour chaque enfant) si le calcul du salaire s'effectue en net (selon les bulletins dits simplifiés des URSSAF) ou en brut.

Quelque soit votre choix, il vous faudra entrer les valeurs de votre choix pour régulariser votre assistante à l'heure et au forfait journalier.

Charges sociales:

Ce sont les coefficients de calculs pour les charges salariales. Ils sont mis à jour depuis le fichier 'taux.txt' (voir aide rubrique raz) et doivent être vérifiés régulièrement afin d'être à jour.

Ils concernent les taux pour le calcul en net, mais aussi en brut alors accompagnés de l'assiette de calcul (si vous n'avez pas d'assiette de calcul dans vos renseignements, c'est qu'il s'agit à priori d'une assiette à 100%).

Congés payés:

Cochez la case "répartis sur l'année" si vous envisagez de régulariser les congés de votre assistante mensuellement ; vous devez alors renseigner le pourcentage du salaire pour le calcul des congés payés (en général 10%).

Cocher "sur le mois de vacances" si vous ne souhaitez pas répartir et préférez régler un salaire sur les semaines de congés effectivement pris par votre assistante. Le logiciel n'intégrera pas le surcoût des congés payés à chaque salaire.

Majoration de fériés:

Si votre assistante travaille des jours fériés (ça arrive !) ; vous pourrez la dédommager en cochant cette case et en spécifiant la majoration accordée.

Lors de l'entrée de vos heures de gardes, vous pourrez cocher "jour férié" en face des journées concernées, afin de donner la possibilité au logiciel de calculer les majorations nécessaires.

Indemnités de repas:

Ce sont les montants que vous attribuez à votre assistante pour la prise des repas à son domicile.
Si vous n'utilisez pas ce principe (enfant mis en garde avec sa nourriture déjà préparée ou inclusion des repas dans les indemnités d'entretien), vous aurez à mettre à zéro ces valeurs.

Comme pour les jours fériés, le remplissage des horaires de garde vous permettra de spécifier quels repas ont été pris à chaque jour de garde.


Indemnités

Attention cette page est à remplir pour chaque enfant gardé (pour chaque onglet).

Cette page est à vérifier et à mettre à jour à chaque utilisation car elle sera enregistrée telle quelle et risque d'être utilisée de façon identique le mois suivant pour le même enfant.

Indemnités diverses:

Entrez directement en chiffre toute indemnité, hors indemnité d'entretien/de repas ou d'absence que vous allez verser ce mois à votre assistante.
Attention: Ces indemnités rentreront dans le calcul des charges salariales.

Indemnités d'absence:

Idem pour les indemnités d'absence qui pourraient être versées (lors d'un enfant malade que vous n'avez pas pu faire garder par exemple).
Ici aussi, les indemnités rentreront dans le calcul des charges salariales.

Acompte déjà versé:

Tout acompte déjà versé sera noté ici afin d'être déduit du salaire net à payer.

Indemnités d'entretien:

Il s'agit là des indemnités que vous pouvez verser à votre assistante pour l'entretien et la préparation des repas.
Celles là ne rentrent pas dans le calcul des charges salariales.

Si vous souhaitez utiliser ces indemnités, il vous faut cocher:
- la case en rapport avec le calcul au taux horaire, c'est à dire que pour chaque heure de garde, le logiciel vous calculera une indemnité d'entretien (fonction de la valeur que vous précisez dans la case concernée)
- la case en rapport avec le calcul au forfait journalier, c'est à dire que pour chaque forfait de jour de garde, le logiciel vous calculera une indemnité d'entretien (fonction de la valeur que vous précisez dans la case concernée)
- soit les 2 cases si vous voulez utilisez les 2 modes de calculs.

Si les cases ne sont pas cochées, inutile de vouloir mettre les valeurs à zéro, le logiciel n'en tient alors pas compte dans ses calculs.

Congés pris dans le mois en cours:

Spécifiez, en cochant la case, si des congés ont été pris pour le mois en cours.
Si tel est le cas, rentrez les dates de début et de fin de congé à l'aide des mini-calendriers.

Si aucun congé n'a été pris pour le mois en cours, décocher la case.


Onglets

Chaque onglet correspond à un enfant en garde (donc 5 au maximum). Ils porteront pour faciliter l'utilisation du produit, le prénom de l'enfant.

C'est donc sur ces onglets que vous choisirez l'enfant pour qui vous allez réaliser les calculs d'heures de garde et l'établissement du bulletin de salaire.

Il faut impérativement choisir un enfant sur lequel on va effectuer les calculs de garde en premier lieu et ne travailler que sur un seul enfant à la fois. Ce n'est que quand vous aurez terminé l'impression et l'enregistrement du bulletin que vous pourrez passer à l'enfant suivant ; cela évitera pas mal de mélanges possible si vous ne savez pas réellement pour quel enfant vous travailler à tel moment.

C'est pour cette raison qu'Assist'Mat Paye vous indique sur chaque fenêtre le prénom de l'enfant sélectionné ; c'est aussi pour cette raison que vous ne pouvez pas choisir d'autre bouton que paramètres au début de l'application.

Remarque : Si deux enfants devaient avoir le même prénom, il est souhaitable de les distinguer dans le cadre "enfant en garde" de l'onglet employeur en spécifiant par exemple l'initiale du nom ; afin de ne pas mélanger les images des bulletins conservés.


ràz pour l'enfant

Ce bouton n'a d'autre fonction que d'effacer toutes les données concernant l'enfant spécifié sur l'onglet en cours ; et uniquement celui-ci.

Les valeurs se remettent alors à zéro ou, pour certaines d'entres elles, aux valeurs actuelles qui sont lues dans le fichier 'taux.txt'

Ce fichier 'taux.txt' peut être téléchargé sur mon site (http://jlperrot001.free.fr) à la rubrique téléchargement / Assist'Mat Paye.
Ce petit fichier contient les derniers taux et coefficients en date ; il est alors à copier dans le répertoire d'installation du programme. (habituellement C:\Program Files\AssistMat).
Il est bien sûr inclus lors du téléchargement du programme, mais pas nécessairement dernier en date...

La présence de ce fichier ne doit pas vous empêcher de vérifier les coefficients et taux que vous utilisez afin de ne pas vous mettre en faux vis à vis de votre employée (eur).


Calculer le salaire

Vous êtes là face à la fenêtre la plus technique d' Assist'Mat Paye ..

Date et heures :

Il faut entrer ici pour chaque jour de garde, les heures [date/heure] d'arrivée et de départ pour l'enfant sélectionné : ou les heures si l'enfant a été gardé avec une coupure dans la journée (enfant scolarisé par exemple).

Si il s'agissait d'un forfait journalier, vous ne devez pas choisir d'heures de départ ou d'arrivée pour la journée... sauf, si vous souhaitez ajouter un certain nombres d'heures à ce forfait. Auquel cas, vous cochez forfait (rubrique suivante) ET choisissez un nombre d'heures supplémentaires à l'aide des heures arrivée/départ.

Forfait, repas et Fériés :

Une fois les heures entrées pour la journée choisie, vous devez cocher les repas pris au domicile de l'assistante maternelle ; si il s'agit d'une journée en forfait journalier (coche forfait) et si il s'agissait d'un jour férié.

La grille :

Se regroupent là toutes les informations que vous donnez au programme pour les gardes.

Vous n'avez pas à toucher à ces données !

Les boutons inférieurs :
boutons précédant / suivant :

Ils permettent de choisir rapidement une nouvelle date sans repasser par la case des choix de dates.

Par exemple, quand vous avez terminé de remplir les données heures, repas, etc... pour une journée, vous cliquez sur le bouton suivant pour changer de ligne dans la grille (et de date par la même occasion).

Vous pouvez cliquer autant de fois que nécessaire sur ces boutons pour trouver la date qui convienne.

Bouton effacer une cellule :

Le bouton effacer une cellule permet de supprimer le contenu de la case de la grille qui est sélectionnée.

Bouton effacer une ligne :

Le bouton effacer la ligne supprime la journée entière qui est sélectionnée dans la grille.

Les boutons de droite :
Bouton annule :

Permet de fermer cette fenêtre sans enregistrer.

Bouton valide :

Permet d'enregistrer les données de la grille pour le mois en cours et pour l'enfant sélectionné.

Attention : L'enregistrement est définitif et irréversible.

Cela permet de dégriser le premier bouton, à savoir le bouton bulletin. En effet, il faut avoir enregistré les données pour continuer et construire le bulletin.

Bouton bulletin :

Permet de construire le bulletin qui sera édité par la suite. C'est la suite logique lorsqu'on a terminé de renseigner les données de garde.


Revoir un mois

La première chose à faire ici est de rechercher le mois et l'année de la grille horaire que l'on souhaite visualiser, sur le [calendrier] en haut et à gauche.
Une fois le mois et l'année affichée sur le calendrier (peu importe le jour sélectionné), validez votre choix par le [bouton Valide]. Les dates mini et maxi de la sélection s'affichent alors.

Dans le même temps la grille s'affiche. Vous pouvez naviguer d'un jour à l'autre au sein de cette grille grâce à la barre d'outils à 4 boutons.
Respectivement, ces boutons correspondent à "premier jour" - "jour précédant" - "jour suivant" - "dernier jour"

Le bas de la fenêtre permet de visualiser les données du jour sélectionné de façon plus claire qu'au sein de la grille même. Ces données se mettent à jour à chaque changement de sélection.

Vous quitterez cette page par le [bouton Quitter]

Note : Vous retrouvez en rappel, le prénom de l'enfant avec qui vous travaillez afin d'éviter les confusions.

Attention : Les valeurs de la grille ne SONT PAS modifiables, puisqu'il s'agit d'anciennes données stockées


Revoir un bulletin

Pour retrouver l'image d'un ancien bulletin de salaire...

Cliquez le [bouton Rechercher]
Choisissez le bulletin souhaité. Les noms des images sont classée de la façon suivante: Prénom de l'enfant + mois du bulletin + année du bulletin.jpg
Par exemple, si vous rechercher l'image du bulletin de salaire de mai 1997 du petit Maxime.... Vous devrez trouver dans la liste (classement alphabétique) "Maxime0597.jpg"
Vous apercevrez une prévisualisation de l'image.
Validez par ouvrir
Celle-ci s'affiche ; vous pouvez à loisir la visualiser.

Fermer cette page par le [bouton Fermer]

Note : Vous retrouvez comme à chaque page, en rappel, le prénom de l'enfant avec qui vous travaillez afin d'éviter les confusions.


Bulletin

Vous êtes arrivé au stade ultime du programme...

A savoir l'édition du bulletin de salaire en net (format simplifié URSSAF) ou en brut pour le mois en cours et pour l'enfant slectionné.

Une boite d'outils vient en surimpression pour vous permettre de cliquer sur enregistrer l'image du bulletin afin de la retrouver ultérieurement (revoir un bulletin). Ceci fait, se dégrisera le bouton imprimer qui va éditer automatiquement ce bulletin de salaire sur votre imprimante par défaut en 2 exemplaires.

Malgré toutes ces sauvegardes, le deuxième exemplaire du bulletin doit être conservé par l'employeur sans limitation de durée (mesure légale).


Date/Heure

Vous trouverez dans la plupart des fenêtre d' Assist'Mat Paye . des fenêtres déroulantes qui permettent de rentrer des dates ou des heures.

Il existe plusieurs possibilités pour les utiliser :

1/ Cliquer sur la flèche déroulante des dates pour ouvrir le calendrier Windows qui permet de choisir la date.

2/ Cliquer sur les 2 flèches pour les heures, ce qui permet de choisir la partie sélectionnée (heures, minutes)

3/ Utiliser les flèches gauche/droite du clavier pour se déplacer au sein des dates (jour, mois, année) et des heures (heures, minutes) et les flèches haute/basse pour choisir la valeur de la sélection.

Ces formats de dates et d'heures nécessitent Windows 98 ou supérieur.

PS: Ne tenez pas compte des secondes pour les formats d'heures !


Sites Web favoris

Utilisation du produit
Calculer le salaire Revoir un mois Revoir un bulletin Enregistrer la version